[hpsdr] Bringing up a home-built Hermes!

Ian Guffick iguffick at iee.org
Fri Jan 25 13:14:31 PST 2013


Thanks to some help off-list by Phil Harman, I seem to have things working.
Thank you Phil.

It turns out all of the 3.3V regulators on the board were outputting
2.1V and the 122.88MHz VCXO was not running.
This was due to the 5V switch-mode outputting only 3V. A bit of
re-soldering on U24 and all the supplies are now fine.
Just a note for anyone else in this situation, the bootload mode
worked fine, but the normal Hermes operation would not connect.

I have another question that I hope someone can answer for me. What
current should the Hermes take in receive?
I previously had 250mA from my PSU, with the 5V supply now fixed, I
now have 690mA when turned on and 750mA when connected and receiving.
I thought this seemed a bit high, but nothing is getting hot (that
shouldn't be)!

Ian Guffick

On 20 January 2013 21:35, Ian Guffick <iguffick at iee.org> wrote:
> Hi,
> I've finally got the last of my components and have finished building
> my home-built Hermes. Many thanks to John Melton for the European
> Mini-Circuits group buy.
> I can't connect to my board and hoped someone would have some advice!
> What I've done so far:
> 1. Powered the board from 13.8V and it takes around 250mA.
> 2. Programmed the EPCS16 with a USB Blaster and the Bootloader.pof file.
> 3. Connected JP12 and used HPSDRProgrammer to load Hermes_V2.2.rbf.
> 4. Removed JP12, repowered and tried to connect - cannot be discovered.
> 5. The flash of LEDs seemed to show that DHCP had not worked, so I
> connected JP12 and used HPSDRProgrammer to write a static address to
> the board. Read back successfully.
> 6. Removed JP12 and repowered, cannot de discovered.
> The Ethernet connection is to my broadband router (Buffalo
> WZR-HP-G300NH), my PC IP is and my Hermes has been
> programmed with a static IP of I have tried connecting
> with both PowerSDR and cuSDR.
> My Leds on Hermes are as follows:
> D1 - On.
> D6 - Flashing.
> D10 - Off.
> D11 - Off.
> D12 - Long flash, short flash.
> D13 - Off.
> D14 - Off.
> D15 - On.
> D16 - Flashing.
> D17 - Off.
> D18 - Off.
> D19 - Off.
> The LED on the Ethernet connector nearest to the 3.5mm jacks is on the
> other is flashing.
> Oh and the 5 LEDs for the regulator supplies are all on!
> When I start a 'network search' in cuSDR, LED D19 illuminates for a few seconds.
> When I 'power on' in PowerSDR, LED D19 and D11 illuminate with D12 flashing.
> I think the board is working enough to rule out a build problem. It
> has power supplies, it is booting from the EPCS16 and has enough
> network connectivity to successfully program and set/read-back a
> static IP address.
> Could anyone help and shed any light on what I'm doing wrong?
> Thanks.
> BR,
> Ian Guffick.
> G7JXY.


More information about the Hpsdr mailing list