[hpsdr] Bringing up a home-built Hermes!

Ian Guffick iguffick at iee.org
Sun Jan 20 13:35:10 PST 2013


I've finally got the last of my components and have finished building
my home-built Hermes. Many thanks to John Melton for the European
Mini-Circuits group buy.

I can't connect to my board and hoped someone would have some advise!

What I've done so far:
1. Powered the board from 13.8V and it takes around 250mA.
2. Programmed the EPCS16 with a USB Blaster and the Bootloader.pof file.
3. Connected JP12 and used HPSDRProgrammer to load Hermes_V2.2.rbf.
4. Removed JP12, repowered and tried to connect - cannot be discovered.
5. The flash of LEDs seemed to show that DHCP had not worked, so I
connected JP12 and used HPSDRProgrammer to write a static address to
the board. Read back successfully.
6. Removed JP12 and repowered, cannot de discovered.

The Ethernet connection is to my broadband router (Buffalo
WZR-HP-G300NH), my PC IP is and my Hermes has been
programmed with a static IP of I have tried connecting
with both PowerSDR and cuSDR.

My Leds on Hermes are as follows:
D1 - On.
D6 - Flashing.
D10 - Off.
D11 - Off.
D12 - Long flash, short flash.
D13 - Off.
D14 - Off.
D15 - On.
D16 - Flashing.
D17 - Off.
D18 - Off.
D19 - Off.
The LED on the Ethernet connector nearest to the 3.5mm jacks is on the
other is flashing.
Oh and the 5 LEDs for the regulator supplies are all on!

When I start a 'network search' in cuSDR, LED D19 illuminates for a few seconds.
When I 'power on' in PowerSDR, LED D19 and D11 illuminate with D12 flashing.

I think the board is working enough to rule out a built problem. It
has power supplies, it is booting from the EPCS16 and has enough
network connectivity to successfully program and set/read-back a
static IP address.
Could anyone help and shed any light on what I'm doing wrong?


Ian Guffick.

More information about the Hpsdr mailing list