[hpsdr] Issue with CW mode on Ozy/Penny/Mercury boards

Ramakrishnan Muthukrishnan ram at rkrishnan.org
Sun Feb 16 11:22:40 PST 2020

I returned back to setting up the boards and this problem that I had reported a couple of months ago has come back (not just on 20m, but on all bands).

The moment I switch to CWL or CWU, Ozy's LED3 starts blinking, which indicates that it is transmitting. Penelope's LEDs also start dancing. I checked the DB9 ports CW inputs for shorts and traced signals till the FPGA inputs for shorts, they all look okay. I also tried connecting both dit and dash inputs of DB9 to the common (ground) on the Ozy DB9 connector and still hear the series of dits. If I connect pin 8 (PTT) of the DB9 to Common (pin 5 of DB9), I hear a series of dot and dashes and it becomes a tone if I untick the iambic mode. Without this input connection, there is no effect on unticking iambic mode, I always hear a series of dots.

In short, even without any CW key input, the moment powersdr is put into CWL/CWU, the radio starts transmitting on whatever frequency it is on (if it is a valid band) with a constant stream of dits. If I adjust the keyer speed, I can see that the transmitting CW speed also changes.

I thought Ozy's key inputs are the culprit for a long time, but have reached dead end. Power supply also seem fine, I don't see any variations. I have tried it with and without the PennyWhistle and problem persists (just to rule out that PA is oscillating..). Ozy LED3 clearly indicates that it is transmitting. Is anyone using Ozy with Mercury and Penny facing similar problems with CW mode?

I spent the whole of today cleaning the boards, looking at the soldering via a magnifying glass and reading the FPGA code. Any clues and debug tips to move forward is highly appreciated!


On Wed, Dec 11, 2019, at 12:30 PM, Ramakrishnan Muthukrishnan wrote:
> ***** High Performance Software Defined Radio Discussion List *****
> Thanks Henry. I am not yet using LPU, but am planning to use one soon. I will keep your note in mind.
> It seem like the tone was because the dit input was somehow getting connected to ground. I used IPA and cleaned the Ozy thoroughly and the problem seem to have gone away. Planning to do more testing. I also need to find a housing for the boards so that the dust does not accumulate.
> 73
> Ramakrishnan VU3RDD
> On Wed, Dec 11, 2019, at 1:07 AM, Henry wrote:
>> ***** High Performance Software Defined Radio Discussion List *****
>> Hi Ramakrishnan,

>> I'm not sure if you use the "LPU" board or not, but I remember there was an issue with the electronic fuses on the LPU-board being too light and they had to be bypassed.

>> I can also imagine another power supply could be current-limiting / oscillating?

>> Anyway, it would be good to check first if the supply voltages are OK (when this happens).

>> Good luck,

>> 73,

>> *Henry - PA0HJA*



>> On 9-12-2019 13:48, Ramakrishnan Muthukrishnan wrote:
>>> ***** High Performance Software Defined Radio Discussion List *****


I have a good old Atlas based system with Penelope, Mercury and Ozy connected to the boards. At this point, I am just listening with Mercury as I do not yet have my pennylane setup and don't have alex boards. So, the antenna is connected to the RF in of mercury. I can listen to stations just fine (with PowerSDR mRX PS, latest available release from the Github) on SSB on every band.

Now, if I switch the band to 20m and push the CWL or CWR button, I get a constant tone - like a series of dits (as if I keep the dit paddle on). If I tune around the frequency, the tone follows there too. I do not have anything connected to the DB25 port of the Ozy. I see the LEDs on Penny (at least the leds 2, 3 and 4) dancing while this is happening, so it looks like it is transmitting when I just switched the receiver to 20m CW. Pushing CWL/CWR on 40m or 80m seem fine and I don't hear the tones.

Has anyone seen this? Or it is that I have setup my systems wrong? I am returning to HPSDR after a very long time, so I may have missed something.. I have latest firmware versions of Mercury and Penelope. I also have PTT explicitly disabled in the "Options" tab under the HPSDR setup. What are the other ways to disable Penny (other than physically pulling it out of the Atlas board)? I am somewhat puzzled why Penny is trying to transmit when I am not transmitting at all. (I don't have a dummy load connected to the output too, so I was a bit alarmed).

Would appreciate advice.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openhpsdr.org/pipermail/hpsdr-openhpsdr.org/attachments/20200217/33850023/attachment.html>

More information about the Hpsdr mailing list